Market on 2.2 Sylvania/Disco - Work In Progress

Hi, just signed up today but have been lurking here a week or so waiting for my tablet to show up then playing around with it:cool: I went ahead and got G-mail working so that was already installed, then I found this thread so I downloaded the beta market listed here and got it to install and it works here as well:D I need to get myself a wifi router but when I found a stable hotspot it slowly loaded then I had all the apps they list so it does work as long as you have Gmail working. I do have the newest version with 2.20 installed so that may be a requirement too but it's working for me as well.
I also need to know what format the microsd cards need to be in as it seems to know cards are installed but so far only uses them when I have it in far 32. Will it work with anything else or is standard fat32 the only format that makes it happy. I would like to be able to load some of my bigger then 4 gig video files to play with without transcoding and things to make them smaller, thanks.
Download the market from here and as soon as you get it downloaded install it straight from your sdcard. As soon as you have the market installed open it and accept the terms of service, then close it. Go to settings, click applications, then manage apps. Click on the running tab. Scroll down and find market and select it. Click on clear cache, then click on force stop. Back up and find the Google services framework, clear the data for this one, then force stop it as well. Next, download this file and copy it into /data/data/ which will overwrite the pre-existing vending prefs file. Now reboot. As soon as you're powered back up, start trying to open the market. It WILL error out on you a few times but it will work. When you get the market to load finally, go back to settings, apps, manage apps, you need to clear markets cache again then force stop it, then go back to the Google services framework, click clear data again, then force stop. REBOOT. As soon as you are powered back up go to the market. Viola, it works.... :)
I downloaded the market and accidently let it load.. it look like it works but do i need to copy the xml file?
And today the only thing really trying to work was the books section so I tried to follow the instructions Xi2wiked has that you quoted. I got as far as the copy the download this file and load it into data/data etc and couldn't find the android app thing maybe because it's not rooted. Figured either it wont work or I might have to reinstall, reset etc.
To my surprise now all the market apps work and I was EVENTUALLY able to download angry birds rio and solitaire, though they took forever to finally actually start downloading and install. Sister is now playing the angry birds variant and reports it plays nice and smooth. The sound is also very loud and clear as I'm in my room in a small house and she's out in the living room and I can hear the bird and game noises very clearly. My Parrot however isn't too thrilled with the other parrots he can now hear and is loudly squawking every now and then about it.
I have been able to install the android market on my tablet (2.20 installed) and download some applications such as Angry Birds Rio. However, some free applications such as Pandora do not show up. Also, if I got to the marketplace through the browser, and check my marketplace settings, it does not show an android_id. When I go to, it thinks the machine is an ipad??
I'm new to these forums, and really appreciate all the help that is available here. I recently got a SYNET7LP (for $70 I couldn't resist) and am getting familiar with it. I really wanted to get the Android Market working. I tried the "chmod 777 /cache" and "chown root.root /cache" steps posted back on page 4 of this thread by cfrockit, but that didn't help. Then when I saw the video posted (again by cfrockit) on page 14 that did the trick! One difference for me was that after doing the Manage Applications steps, when I restarted Market I didn't get any errors -- things just started working.

Many thanks to those who contributed to this forum!
Last edited:
Heres my post on how to get the market running, the easy way....

The second download link only seems to open a browser page. Am I missing something? How do I download the file to transfer to the shared_prefs file? Thanks!

Edit: Nevermind figured it out. :)
Last edited:
The second download link only seems to open a browser page. Am I missing something? How do I download the file to transfer to the shared_prefs file? Thanks!

Edit: Nevermind figured it

i am missing this one pls tell me how to do this part
I cannot watch the video by cfrockit on page 14. It says it is private, even when I'm signed in......anyone know why? Is there a direct link?