Market Stopped working for no apparent reason


Aug 25, 2011
Android version: DG2.20
Kernel version:

The Market was working fine on this tablet for weeks. No issues whatsoever. Now, suddenly I can see almost no apps. A search for just about anything only returns hits for books. I tried to go in sideways from Andropit, and every link to the Market I get shows the app, but has no option to install.

I've tried the usual way to fix the market (clear cache, force stop, then clear data and force stop on the google services...etc) and it has had no effect.

I did a 3 finger reset, and tried to fix the market again. No go.

I downloaded the latest firmware for the tablet ( and loaded that up....exact same issue.

Not sure what to do here.
Same issue here with Market 3.1.3!
Re-installed beta4 after Settings > Privacy > Factory data reset - to clear all settings
Manually changed the Android ID to equal Decimal and Hexadecimal values in both "Google Services Framework" and "Settings Storage" databases.

"Google Services Framework" > gservices.db > main > android_id (decimal value)
"Settings Storage" > settings.db > secure > android_id (Hexadecimal value)

Reverting back to Market 2.3.6 with "Ugly Hack" to see if any applications will show or if it's a build.prop "" issue where the Market servers have been updated to report "Your device is not compatible" therefore don't bother showing the applications.

Good luck and post any results.
I am dead in the water. I've tried everything I can think of, and a few things that I yanked directly from out of my butt. Even a complete wipe and reload of the system without using any recovery software (like Titanium) has had no effect. I am beginning to get the feeling that something has changed on the Google side of the equation.
Ok...small win here. I got my hands on the Eris Market Fix, and this opened up a lot of missing apps. However, it was detecting my tablet as an Android 2.1 (Should be 2.2)

Anybody got any ideas here?
As I understand it, the Eris Market fix edits the Build.prop file and makes it think it's a different phone running 2.1. So, does anyone know how to mimic this fix for a phone running 2.2?
Ok....let's see if we can reason this out.

I am attaching my broken build.prop and also the one that restores most apps.

The problem with the partially working build.prop is that it is detected as Android 2.1

I need it to see that it is 2.2

View attachment $
Does anybody have a working market on a 7LP? If so, can you post the build.prop file? It should be located in /system
Downloaded SGS Tools and altered the fingerprint to:

Seems to be working so far (but Netflix is not showing in the search....big whoop at this point)