Problem with Polaroid Tablet Model Q10 and SD cards.


Junior Member
Nov 4, 2015
My name is Karl. I have a Polaroid tablet Model Q10 I bought at Menards back in December 2014. I have only a few times tried to use a 8GB MicroSD card and a 16GB MicroSD card (32GB max) but have been unable to change the Camera Save Position to settings to external and it says "There is no SD card, need to save to the phone."
It defaults to internal. I have been unable to use the Camera because of that. I had to get a bigger card (16GB) for my phone so I would be able to take more pictures on it. I tried resetting the tablet, not for that reason. I have been having other issues with it, but those are on different topics. Resetting the tablet did not fix the issue with the SD card. I forgot to mention that when I insert a card with photos and videos on it I can view the photos and videos, I just cant save photos on the card using the tablet's camera.

Please help, about ready to toss this thing.

Info on Tablet: From "About Tablet"
MFG: Polaroid
Model #: P10/Q10/PTAB1040/PTAB1041
Android version: 4.4.2 (KitKat)
Firmware version: 4.6_20140510
Kernel version: 3.3.0
inet_hgb@supperFAE #5
Fri May9 20:33:58 CST 2014
Last edited: