Viewsonic Viewbook 730


Oct 27, 2011
Just got my Viewbook 730 and about everything I've read about the device is basically true, although I think there are some things worth mentioning:
1. Yes, it's not as well built as the Nook Color, but it's much better than the knock offs. Not making excuses here, but it's in between the better chinese tablets and the nook color. I'd rate it just a slight drop off from the gTablet.
2. It's screen is a bit of a weakness, but what the biggest issue is the lack of multi-touch. You just tap the screen to zoom, so it's not that bad but it's not as elegant as a multi-touch tablet. BUT, before you lump this screen in with the best resistive touch screen you've used, it's better than that. I cannot tell it isn't capacitive. Seriously, it touches and acts and is so smooth that you cannot tell the difference. It has a glass surface and you can draw on pictures and things really well, but from a technology standpoint the negative on the screen is the lack of multi-touch - not the underlying touch technology. (Another negative here is the device's resolution is only 800 x 480)
3. HDMI, camera and mic, slightly larger screen than NC, run Skype, as well as full set of capacitive android control buttons are all plusses.
4. The software is really funky. After running CM7.1 and others on other tablets, their stock 2.2.1 is just kind of clunky. Unfortunately nothing much found on rooting and custom roms - but that's critical. The platform (samsung A8) should be a fertile ground, but nobody as dumb or daring as me??

So far I've installed about everything I can find and no issues to speak of - but the 800 lbs gorilla is Android Market and google apps - so that's a priority for me.

I have managed to find out the following:
If you hold the power key and either the + or - volume key it will boot into Recovery mode. Gives you the option of installing software from the SD card, or recovering the system (and this clears everything back to stock), and you have the option of clearing the screen lock password (not sure if this wipes user data as well??) and, of course you can reboot or power down from this screen.

The system about:
Android 2.2.1
Kernel 2.6.29
Build Number is v1.00.08-Froyo

I just started to figure out how I can get this rooted but so far having trouble getting my computer to connect to it in ADB.

Hopefully others will submit their observations. I'm hoping I'm not the only one.
Well, that's quite a first post on the forum. Glad you decided to join us here at Android Tablets, welcome to the forum. I sure hope the user data gets wiped if you wipe the screen lock password. If not, what's the point of the PW?:) Nice post.:cool:
I rooted my VB730 today (and basically had to fight Beelzebub to get it done). The trick is a long one and requires you doing quite a few bits of gymnastics to get it done. I'll post a guide below.

My opinion... this thing is a bit buggy. I've had it for a couple weeks and things... just don't seem to work right all the time.

First problem is, I bought a micro SD card and I can't get the thing mounted where the device can see it. I can format it and then it mounts but as soon as I turn off the device and turn it back on, the card needs to be formatted again before it will be recognized. Kinda defeats the purpose of having an SD card.

I'm curious as to where you got your skype (android market simply won't work). I managed to find an older copy but there's a problem - you can make a call but once the other end picks up, it's an instant hang up. Strange. I'm wondering if this is an old bug that got fixed but with no market access, I'm having a hard time finding Skype.

You're right about the lack of ROMs available and it's sad. But it seems like more and more people are getting this device now so we may see some new developments coming along (I hope!). I'd have to agree that this thing is actually quite a nice device for the price and if we just had some customization going on, it'd be well worth it.

Now on to the guide!

How to root the ViewSonic ViewBook 730 (on a Windows' system):

First you'll need to install the usb driver (which was a pain in the rear and ViewSonic was far from helpful). After you get that done, you'll need SuperOneClick but don't use SuperOneClick directly, it won't work. The files for the VB730 are not in normal places. You'll have to do it manually. I followed guides from a couple of places taking the pieces I needed.

Here's the steps compiled into one nice package:

  • download and install Google USB driver here
  • open file android_winusb.inf from the driver's directory. Find section [Google.NTx86] (if you have 32-bit Windows) or [Google.NTamd64] (for 64-bit). At the end of the section, add the following lines:
    ; ZMS-08
    %SingleAdbInterface% = USB_Install, USB\VID_2350&PID_0102
    %CompositeAdbInterface% = USB_Install, USB\VID_2350&PID_0102&MI_01
  • find the device in Device Manager and update driver using previously installed USB driver (once finished, you may need to restart your device)
  • add folowing line to %HOME%/.android/adb_usb.ini (note! %HOME% refers in windows to c:/users/<YOURUSERNAME> or C:\Documents and Settings\<YOURUSERNAME> in case anyone else can't figure this out):
  • restart server
  • Download SuperOneClick v2.1.1 from ShortFuse (a direct link from here)
  • Pull out the su-v3, busybox, Superuser.apk, psneuter, and GingerBreak files from the SuperOneClick zip. Rename su-v3 to su, and place the files in your ADB Platform-tools directory (or wherever you run ADB from)
  • Open the command prompt and find your way to your folder with ADB (and other files you just moved)
  • Start the commands:

adb devices
adb push psneuter /data/local/tmp
adb shell
$ cd /data/local/tmp
$ chmod 777 psneuter
$ ./psneuter
adb kill-server
adb devices
adb shell

This should give you temporary root access. There should be a # symbol on the left. Next, you need to exit the shell and then do what SuperOneClick does and change a few things:

adb push su /sbin
adb push busybox /data/busybox/busybox
adb install Superuser.apk
adb shell
#chmod 4755 /sbin/su
#chmod 4755 /data/busybox/busybox
adb pull /system/ziilabs/init.rc

This last file is the one causing a problem. You need to open it on your computer in a text editor (wordpad worked great for me), and find this line:

mount ext4 /dev/block/mmcblk_data1 /data nosuid nodev noatime nodiratime

And you'll want to change it to:

mount ext4 /dev/block/mmcblk_data1 /data nodev noatime nodiratime

Save your file and then push it back to the VB730:

adb push init.rc /system/ziilabs/init.rc

Then, type:

adb reboot

This will reboot your VB730 and you'll have root!
Last edited:
Eyowzitgoin: Thanks for the work on rooting. I did manage to get my ADB connection working - not sure why it didn't last night, but I reinstalled the SDK and kind of did a clean start and it worked!
As far as rooting, I followed your instructions and no dice. I get temp root as needed to do all the pushing, pulling and chmods but when I get done it's still not rooted. I tried some variations on your find on the init.rc file, but that didn't seem to make a difference. I even went to the SuperOneClick program and did a root with psneuter and it went all the way through the rooting process with 100% OK's on every step except at the end it said, success! and Do you want to run a test to verify - and, well, you guessed it, it failed.

At the moment I went on to getting market up and running - along with Maps and GMail. etc. Simply a matter of adb pushing the apps to the /system/app and a few other directories. I used the info from this page:
and it works, but it's not 100% complete for all the apps. I intend to work on that to get the other functions working right. But, market and gmail and maps are running fine and I was able to go through a "normal" sign-in to get to my google acct.

Back on the rooting issue (and maybe your issue with mounting of the ext SD card). I noticed something strange on my Viewbook. First, I was surprised to find Root Explorer installed on my machine. This was a factory reconditioned unit so I would have expected it to be wiped completely - and root explorer isn't a free app. So, my question is, did you get Root Explorer with your unit? My suspicious mind makes me think zii included that app for a reason which may have something to do with the oddball file locations.
How about sending me your init.rc file and if you want I'll send you mine. Maybe they are different???

If you get the nerve to install one of the Creative Rom updates on your 730 let me know. The units look 100% identical so gotta believe other than the Viewsonic boot images these devices are the same. Maybe safer to get someone who has a Creative ziio 7 to send us their init.rc to check over first.

Playing with the 730 tonight I'm liking it better. Not too bad.

Oh, by the way, I downloaded skype from Amazon App Market. It was one of the first apps I downloaded for this tablet. I think it was an updated version from the one I have on my other tablet. I made a test call and a call to my own cell phone is all I've done with it so far. The call was fine - although not nearly as good as from my netbook or laptop and it was hard to keep the sound from broadcasting the creaking of the case in my hands as I talked. (maybe a little flocking if I get it apart someday to stop the squeaks and cracks). Skype shows the option of video, but I haven't tested that yet. Also, when I use my camera it's at a bad angle. I wish these guys would do a little more engineering with these things. Such a simple thing to get the camera pointed correctly. If I ever bust open my 730 I intend to fix that. I have read somewhere that it doesn't show you - just the person you're calling.

Thanks for your work on rooting and if you have any more tips please post them.
I just realized I neglected to quote my sources. :eek: So let me do that first. They were mainly from xda-developers' posts.

I followed the guide mainly from this thread:
And this one:
And the start of the actual rooting from another outside source here.

Many thanks to these guys!

As for a lack of root on yours... that's odd. I went through SuperOneClick the way you did as well and I had the same problem - no suid. After I finished my way, I see that I have root because I'm able to allow programs root access and modify root files. But in trying to modify my hosts via a push, I found I too lacked suid capability. Very strange. Perhaps I don't have full root either? To be honest, this is my first droid device and I've only had it a couple weeks so I really know next to nothing about them yet. :eek: I did notice in the notes of the init.rc file that they say "We chown/chmod /data again so because mount is run as root + defaults" and the again part makes me wonder. I don't know if they are just chown/chmod-ing the data folder a second time since they added the "nosuid" and others or are they adding these files a second time and chown/chmod-ing it all a second time. I'm not too familiar with linux code and the way things work yet so I may be looking at nothing here, but if it's the latter, there may be one more file we need to remove the "nosuid" from. I'll be glad to send my init file to you.

I don't believe I have root explorer installed on my machine. I've not noticed anything that relates to it but I'll have to take a closer look later (when I'm not at work) and let you know.

Many thanks to you for the link for getting the market installed! Much appreciated! I was beginning to think I'd never get it done. And actually, as of now, I still might not get it done because the megaupload file is apparently "unavailable" in my area. :( Don't suppose you know of anywhere else I could get the file or you could pass it my way? :D

I also noticed in that post that I am not the only person having the troubles with Skype. It seems some of the ZiiO users are having the same problem. They don't seem to have come up with a solution for it yet from what I can tell. There's a clue in that there might be a block in the Skype application similar to the one they used when they first launched video calling on only selected devices. But why it works on yours and not mine is a mystery. I'll have to keep working on this one.

I contacted ViewSonic support last night about the SD card (it's a very odd problem) and... wouldn't you know it, they had no help to offer other than "try a smaller card, it might work". Not much help considering this card is stated to work for the device and I already bought the thing. I did try a smaller SD card though and it wasn't the problem. They are supposed to get back to me on the issue but I wouldn't hold my breath. I'm going to guess I'll have to figure this one out on my own too.
Scratch that part about needing the file for market apps. I just turned on my proxy program on my laptop and went through it. :) Google apps are running now! Thanks again for the tip!!
For your SD card issue, have you taken a look at this page? Android Booting - I found it a lot easier read than the google docs. I'm a rookie also and I haven't played with linux since the early 90s (debian). It's coming back to me a bit at a time but I was never that up on it even then.
My SD card is fine and prepares fine every boot.
I'll postup my init.rc as soon as I can get to my other laptop. Heading to the game!
After following the rooting procedure in post #3 I still couldn't get Titanium backup to run. When I ran Superuser it just gave me the base screen with no entries for the root apps I had tried to run. So, no root.
Root Check showed the following:
Root Access is not properly configured or was not granted.
Superuser.apk - - version 3.0.6 is installed!
System Environment PATH: /data/busybox /sbin /system/sbin /system/bin /system/xbin
The adb binary is set to default shell user access as a standard non-root user
Standard su binary location: ls -l /system/bin/su:
-rwsr-xr-x 1 0 0 26324 Nov 2 15:37 /system/bin/su
Standard su binary location: ls -l /system/xbin/su:
-rwsr-sr-x 1 0 0 26324 Nov 2 15:37 /system/xbin/su
Alternate su binary location: ls -l /sbin/su:
-rwsr-xr-x 1 0 0 26324 Jul 25 19:35 /sbin/su
Alternate su type binary location: ls -l /system/xbin/sudo:
ls: /system/xbin/sudo: No such file or directory
SU binary not found or not operating properly
Results provided on your ViewBook 730 device by Root Checker version 3.9 from joeykrim in the Android Market
The SU entry in /system.bin may have been my doing as I was trying different locations for the files...
I then ran Root Check on a gTablet I have which is rooted with a custom rom and Froyo 2.2. Here are it's results:
Congratulations! You have root access!
Superuser.apk - - version 3.0.6 is installed!

System Environment PATH: /sbin /system/sbin /system/bin /system/xbin

The adb binary is set to default shell user access as root

Standard su binary location: ls -l /system/bin/su:
lrwxrwxrwx root root 2011-10-14 11:09 su -> ../xbin/su

Standard su binary location: ls -l /system/xbin/su:
-rwsr-sr-x root root 26264 2008-08-01 07:00 su

Alternate su binary location: ls -l /sbin/su:
/sbin/su: Permission denied

Alternate su type binary location: ls -l /system/xbin/sudo:
/system/xbin/sudo: No such file or directory

Root user id:

Root group id:

Results provided on your UPC300-2.2 device by Root Checker version 3.9 from joeykrim in the Android Market
There are some obvious differences.
I noticed the locations of SU were a bit different and incl a symbolic link. That caused me to go back to linkkero's post. There was a line to remove the SU from busybox and that got me to thinking it could be superuser is having trouble finding correct versions/locations.
So after getting root shell with psneuter I ran the additional line:
rm /data/busybox/su

One thing I noticed right away was when I ran root explorer the next time it went through the "Allow" root access dialog!
Ran root check again, but it gave the same result and titanium still wouldn't run.

Next I removed the /system/bin/su and replaced it with a symbolic link:
ln -s /system/xbin/su /system/bin/su

Ran Root Check again and even though I now had some of the files right and in the right places it still wasn't giving me root success. The problem was looking more and more to be a problem with adb.
Searching around I found a reference to "updating Superuser" and I remembered seeing a notice to update superuser (which was a new notification...)

Ran superuser, and went into preferences, "tap to check for update" and then updated. It ran the script run and was getting all OKs till it hit the remounting /system as RO. That failed? Why would a /system directory refuse to be changed to RO when I had root access? I also remembered that I haven't been able to get root explorer to change my /system file from RW to RO.

But, when I ran titanium backup the next time - SUCCESS! I ran a backup of everything and that worked fine, so I would assume I have root.... except here is my latest root check:
Root Access is not properly configured or was not granted.
Superuser.apk - - version 3.0.6 is installed!
System Environment PATH: /data/busybox /sbin /system/sbin /system/bin /system/xbin
The adb binary is set to default shell user access as a standard non-root user
Standard su binary location: ls -l /system/bin/su:
lrwxrwxrwx 1 0 0 15 Nov 2 19:08 /system/bin/su -> /system/xbin/su
Standard su binary location: ls -l /system/xbin/su:
-rwsr-sr-x 1 0 0 26324 Nov 2 15:37 /system/xbin/su
Alternate su binary location: ls -l /sbin/su:
ls: /sbin/su: No such file or directory
Alternate su type binary location: ls -l /system/xbin/sudo:
ls: /system/xbin/sudo: No such file or directory
SU binary not found or not operating properly
Results provided on your ViewBook 730 device by Root Checker version 3.9 from joeykrim in the Android Market
Still root check has it as not rooted, but, titanium works, root explorer works, and I can get to a # prompt in android terminal with a simple su command (it brings up the Superuser "allow" dialog the first time. When I go into Superuser I see those apps as all allowing root access.

That's my progress to date. At this point I'm stuck until I find out more about the ADB file within the device and why it isn't as accessed as root and why I can't change my /system directory to RW.

Anyone have any ideas?
I'm trying to follow Eyowzitgoin post, but I get stuck at the point I should enter the code in adb_usb.ini Actually, when I get to c:/users/<YOURUSERNAME>/.android/ there is just not such file... I'm using Windows 7 SP1

Thanks for any help!
If you cannot find a file by that name, you will have to create one. Simply create a txt file and into the file place:

# USE 'android update adb' TO GENERATE.
Once you're done, save it and then rename it to the desired name (adb_usb.ini).

Also, don't simply follow my guide but read on to AmericanDane's posts lower down. My initial root claim was a false positive and you can get a much closer (though still as of now incomplete) form of root by following their instructions after you finish the bits in my guide.
I think to get closer to root the symbolic link in the /system/bin directory is important and the process of going through the Superuser application and then doing an "update" of that program is important. Without that, Superuser will not perform correctly.

We still have a problem with "full" root as applications like setCPU will not run, but many other root apps do run.

The fact we can't get the full root is probably related to how Zii Labs implemented the /system directory and it's secure bit - and that's probably part of the bootloader which I don't have a clue how to get to. But we still should be able to get that fixed.

I can run 90% of root applications and the one I was really after was titanium, so it's a step in the right direction. And you can install system apps like all the google apps which is also nice.
Last edited:
Hello guys,
I appreciate the efforts you are doing and I'm looking forward to a custom ROM for the Viewbook 730. In the mean time could you please post a walkthrough to replace Amazon Market with Google Market and get hold of all major apps like Gmail, YouTube, Maps, etc? I guess this would be much appreciated, since most basic users (like me...) are after that. Thanks!

Concerning the reported problem with SD cards, I can confirm that 16GB SanDisk ( do not work (same behaviour as that reported by Eyowzitgoin). I own two vb730, which I bought for my kids and tested two identical 16GB SanDisk SD cards with them, so I guess the problem is real. However, I also tried another 16GB SD card that I had sitting in my phone (unfortunately I cannot identify it...) and it works on both units. Therefore I do not think the issue is related with card size.
Last edited:
Someone can probably do a better job, but, here's my
1. Follow all the instructions in Post #3 to get your ADB connection working and have psneuter available (I would recommend you put it in your platform-tools directory along with ADB.)
2. Download to your PC the google apps for Froyo here:
3. Unzip all to a location you can easily get to from your platform-tools directory on your PC.
4. Decide which apps you want to install (you could do them all, EXCEPT DO NOT INSTALL SetupWizard.apk). SetupWizard conflicts with the VB so do not copy it over.
a. The files I used were:
1. All the /system/etc/permissions files
2. All the /system/lib files
3. The /system/framework file
4. In the /system/app folder, I did the following:


(You could do all the apps except for the SetupWizard if you wanted, but you can also install them later from market. I'm not real sure why the HTC files are included there so I would probably stay away from those, but if you do the files I installed you will have a very complete market and gapps experience.)

5. Now that you know what files you want it's time to connect your Vewbook to your PC.
6. Within your platform-tools directory it would be easiest to place the files you want to push in that directory - just make a list of them so you can check them off as you go. I would also do the permissions, lib and framework files first, and carefully, as they all have to be in that particular directory on your Viewbook.
7. On you PC start up a cmd.exe dos box.
8. On the PC in the dos box, cd to your adb directory (i.e. /android/android-sdk/platform-tools)
9. ADB devices (That will start your server and you should see a string for your Viewbook as connected. If you don't go back to post 3 and get it working)
and the following commands:

adb push psneuter /data/local/tmp (copy the psneuter file to your Viewbook)
adb shell (open up a shell on your device)
$ cd /data/local/tmp (you don't type the $ as it's just your prompt)
$ chmod 777 psneuter (get comprehensive permissions on the psneuter program)
$ ./psneuter (execute psneuter)
$ exit (exit the shell and get back to your dos box)
adb kill-server (need to restart the server so kill it)
adb devices (restarts the server)
adb shell (now go back to shell only now you should have a # prompt)
# exit (exit the shell after you verify that you are root)

10. Now push all the files from your dos box as follows:
adb push (completefilename) /system/(dir)/(completefilename)

for example:
adb push Gmail.apk /system/app/Gmail.apk

The () are just to indicate you need to put in the proper directory and complete filename. Remember this is case sensitive,
so type the names in carefully. Do that for each file to your Viewbook to the appropriate directory.

11. When you've pushed all the files go to shell to set permissions as follows:
adb shell
# chmod 755 /system/(dir)/(completefilename)

Do that for all the files you pushed including the lib and permissions and framework files (not sure if it's needed??). You can use your list again and check them off so you don't miss any.

12. After you're sure you have pushed all the files to the proper spot and chmoded the permissions, then exit and reboot your
viewbook (you can issue the command adb reboot if you want)

13. When your Viewbook reboots just go to a program icon like market or gmail and hit it. That will fire up the sign-up process.
(make sure you have wireless up and running before you do this).

In a nutshell what you've done is:
Got a working ADB connection to your Viewbook from your PC.
Installed psneuter to your Viewbook where you can get temporary root privileges.
Pushed the google system apps to your /system directory along with supporting library and framework files.
(chmodded them to correct permissions)
Rebooted to get a clean slate to go through the sign in process.

(all of this I got from others, and I know very little about these devices as I am just learning)
Last edited:
Market with the standard build.prop file on the Viewbook 730 is very complete and works well. But there is an issue of the scrolling.
If you do a search and you have the screen in portrait position you may only get one screen worth of results. Simply turn to landscape mode and you will be able to scroll.

I have had the update function on "my apps" seem to freeze. Everything worked fine once I rebooted, and I'm not 100% sure it was actually having a problem and possibly was just bogged down doing so many at once, but I did have a freeze. After rebooting things just picked up and ran fine and updated fine.

About the only app I really want that I haven't been able to make run (so far) is Fox Business. I don't know why, but this app is really finicky. It works on my Pocket Edge (froyo) but not on my gTablet or other android tablets...