Disgo 6000 Stuck at Boot Screen - Factory Reset Fails


Nov 21, 2012
Hello, first time poster....

I was recently given a Disgo 6000 tablet that came with 2.2 out of the box which is stuck on the DISGO arrow screen. I have tried resetting the tablet (including long press for more than 10 seconds), the 'three-finger salute' and a few other ideas I've seen around the place, but nothing seems to get me any further along.

I understand that the Disgo 6000 that ships with Android 2.2. is a bit more flaky than the standard model. I've seen lots of mentions of IUW but I don't really understand it, and some commenters seem to suggest that using IUW for the 2.2 version of the Disgo 6000 will result in a brick.

Can anyone give me any ideas for how to get this tablet booting again, please?

Thanks for reading.
I found the "How to manually update..." thread amongst the stickies, and it looks promising, but it says right at the top DO NOT USE THIS METHOD IF YOUR TABLET CAME WITH ANDROID 2.2, so I'm no further along.
Flashed the only disgo IUS file using IUW burning to an SD card and it worked, so I now have a booting tablet. What a horrible touchscreen it has though! And is it just me, or is it impossible to get it to 'sleep'?