[RECOVERY] S7 Clockworkmod Recovery Port for Android 2.1 Builds

I've had no problems tethering my tablet under either the telstra rom or the singapore rom.
I use barnacle wifi to tether.

Sent from my sdk using Android Tablet Forum App

Should have read the forums better. I actually didn't know that and was trying the older wifi tether which required iptables. Oh well I guess it doesn't hurt that I got it working, right? :D
Should have read the forums better. I actually didn't know that and was trying the older wifi tether which required iptables. Oh well I guess it doesn't hurt that I got it working, right? :D

I am sure you enjoyed the challenge :)
Download recovery.img from 1st post Flash recovery using the 2nd post poweroff key combination menu>send>power to use the recovery
Niice mate,

Might play around with it sometime lookin at the framebuffer crap after I at least get gingerbread on my S7 :p. (Huawei were 2 slow to get Froyo on it :p).
Didn't try the windows installer, but, fastboot worked, nasty telstra single SD here.
I got everything working great so far occassional FC's for the "media" will note exact FC later. I was trying to get the Singapore ROM to load from the external SD but CWR would not/could not see my external card. I tried to unmount -remount the card that did not work either. The card is a 16g, formatted fat32, not sure if the size makes a difference. I tried to run zip by browseing and same result. Finally put zip on internal card and succeeded. Set CPU and will update titanium back up. Not other issues so far.

question: if using Eclipse to build a rom package since my current level of understanding is eclipse is building in a modular basis, the different modules are based on what the builder wants to do. Are the modules that are useable based solely on the Android base version i.e. 2.1 or does the processor come into play as well? Like arm7 processors will handle what xx processors will not? Trying to build a big picture to understand how all of this fits together. Thanks X for the turorials posted and making me figure out some of this on my own. beer money to follow.
I set the recovery to read from internal memory by default, and didn't develop anything that lets you swap back and forth.

You might want to ask your other questions in a different thread, and I am probably not the right person to ask. , but both the processor and Android version can come into play depending on the type of target instructions the module you are building has.
How do I/we change from the internal to the external sd card? Could not determine that from the menu's

How does using Apps2SD (or Link2SD) affect this mod? I'm using Apps2SD, and it doesn't appear to backup "data" from the 2nd partition.

So, I guess the question is: does this mod affect stuff on the second partition (data, davlik-cache, etc)?
There is no option to have the recovery toggle between the internal and external SD. Please just work with the internal one.

Using Apps2SD has nothing to do with installing custom recovery.
Let me re-phrase that then.

I installed custom recovery. I did a backup. The backup does not include stuff on the second partition (the data.img is around 11MB, should be much larger). Likewise, I believe that doing things like "wipe dalvik-cache" don't work when dalvik-cache is on the second partion.

Does custom recovery check for the second partition? Or does it assume that the info is located on the standard partition (ie the 175MB we see before Apps2SD)?
The apps2sd stuff is supposed to go into a file called ext2.tar. If it isn't generated, the recovery is not dealing with the ext2 partition properly. I am thinking the single SD recovery might work better.

I had run into some issues with force closes, that resulted in a boot loop (it'd make it to the homescreen, then reboot, no indication as to why).

I had installed the recovery, and made a couple backups. I booted into the recovery, tried restoring a backup, reboot, same loop. From recovery, tried formatting, wiping, etc data, cache, system partitions. Restored, same issue.

Unfortunately, I wiped my internal drive this morning while re-installing and re-doing apps2sd, so I can't check if there was an ext2.tar file (I don't recall). I will re-install recovery later and do another backup, and post the results.
Installed recovery, did a backup. Failed to mount sd-ext (...mmcblk0p2). Thinking about it on the way home. Tried again just a moment ago, except this time I removed my SD card. Ran a backup, worked just fine, found sd-ext, backed up all the data on it.

So, to recap.
s7-104 (best buy, 8gb int, sd card slot)
remove sd card
recovery sees the 2nd partition for apps2sd and can make a proper backup. (internal card is mounted as mmcblk0)
other functions may or may not work properly, didn't test.

if the sd card is inserted, recovery mounts the external card first (as mmcblk0) and fails to find the 2nd partition on the internal card.