Alternate (long) method for ICS on the 7022 (ICS, Gapps, Root)

I am using HCL ME X1, which is the re-branded version of the Coby Kyros MID7022 for the Indian market.
The link Consumer Entertainment Products for Home, Office or On the Go! | COBY is showing "Due to technical reasons this page is not available". Is there any other link to update my tablet to Android 4?

They made it available to only the German users. You have to go through a proxy if you are not located there... if you do, then the link will show up at the bottom of the page.
Hi Guys,
i'm trying to root my MID7022 for a while but with some troubles.
First of all some facts:
Installed Android SDK - check
Downloaded additional Google Android Drivers over SDK - check
Correctly installed Android Drivers while Tablet is connect to PC - check
Clockwork Mod Recovery File in Platform-Tools folder of Android SDK - check

To be sure that i have access to my tablet i tried some adb commands like adb devices, adb shell and adb reboot and all of them worked.

sdk\platform-tools>adb shell
shell@android:/ $ exit

sdk\platform-tools>adb devices
List of devices attached
.memtype=2 device

sdk\platform-tools>adb reboot


Of course i have activated usb debugging otherwise the commands wouldn't work.


I took this Coby | Tutopials Guide and i stuck at this point:
fastboot flash recovery recovery.img

sdk\platform-tools>fastboot flash recovery recovery.img
< waiting for device >

Nothing happens. I also booted the device into FWDN mode (power button + home button) where you can see the blue words that say "waiting for connecting to pc" or something like that. BUT, if my tablet is in this state, the device manager of my laptop recognized the connection and shows correct installed drivers.

I also tried to use superoneklick. It installed some drivers but when i click on root i stops at the point "waiting for device" (i think it was point 7) and nothing happens.
ROM Manager is installed on the tablet but when i want to install the "recovery" addon from the rom manager, it doesn't list my tablet.

Info about my tablet:
Android Version 4.1.1
jim@build-165 + 1455
Build-Number GreenDemon_v1.0.0035

My Laptop is an HP Elitebook 8560p with Win7 Prof. x64.

Please let me know if some informations are missing.
Hi pseiko, welcome to the forum. Nice of you to become a member of Android Tablets. Sorry for the delay, but the forum software moderated your thread because of the link in it. When that happens, a member of the moderation staff has to approve it. Enjoy the forum and your tablet!:)