[Discussion]Building the S7 kernel


Dec 25, 2010
I know there are at least a few people working on building a custom kernel so i wanted to start a discussion in hopes of getting the work done.

I have very little experience compiling kernels but I have a fair amount of Android experience and I have been building Android ROMs for some time. I have researched the topic of kernel compilation and I have worked through a lot of the process but I am unable to compile a bootable kernel. Here is where I am....

My first step is to just try and compile the stock Huawei 2.6.29 kernel (source available here). I am getting an error when building...

  LD      drivers/input/cypress_120/built-in.o
arm-eabi-ld: error: drivers/input/cypress_120/cypress_firmware.c:34:3: syntax error, unexpected STRING
arm-eabi-ld: error: drivers/input/cypress_120/cypress_firmware.c: not an object or archive
make[3]: *** [drivers/input/cypress_120/built-in.o] Error 1
make[2]: *** [drivers/input/cypress_120] Error 2
make[1]: *** [drivers/input] Error 2
make: *** [drivers] Error 2

Obviously the problem appears to be related to the cypress touch screen drivers but I can't figure out the issue. If I compile the kernel without the cypress drivers then it compiles fine but of course it does not boot.

So my questions...

1) Does anyone know why I am getting the above listed error?
2) Is there anyway to test/debug a kernel before flashing it to my device?
3) Any other input or advice?

If we can get the kernel patched and built then we can move forward with the recovery port and get some custom ROMs going.
i've got the this error on compile too, anyway i've compiled kernel without the cypress dirver just for the test
the kernel boots fine but stuk on
service zygote /system/bin/app_process -Xzygote /system/bin --zygote --start-system-server

and just restarts boot animation

for debuging you can use fastboot -c console=tty0 your_kernel_image your_ramdisk.gz
you can remove the cypress touch and I've gotten the kernel to boot fully without a issue :) (using fastboot and then flashing it and having it boot fine besides some sdcard issues but those can be fixed)

to remove it, just edit the .config
oooo......getting excited again....and a quick reminder...the bounty is STILL out there!
I have been flashing with flash_image and I get nothing but a boot loop. I will compile again and see if I can get fastboot working. I have tried fastboot a number of times and can not get it to recognize my device, when I boot in to the bootloader and do "fastboot devices" there is no output.

@pbrauer, I am excited too. I really want to get this going. We already know that clockworkmod recovery is essentially done it just needs a little kernel boost to be fully functional. I can smell the froyo from here...lol
Last edited:
you don't get a ????? as a device?

regardless while its on fastboot, do the fastboot boot kernel command :)

I'll setup a github with the kernel and we can all work from there...
Last edited:
you don't get a ????? as a device?

regardless while its on fastboot, do the fastboot boot kernel command :)

No, I get nothing. I will give it another go tonight.

Sent from my nonsensikal froyo
Maybe it will help to know that are more way to enable the usb port for debuging.
With this code we have acces to the Test Menu. Using the Phone software key type this.

How are you guys getting in to fastboot on the device? I have tried hardware keys (forget which keys) and adb reboot bootloader. Any way I do it I get...

brian@brian-Presario-C700-Notebook-PC:~$ adb reboot bootloader
brian@brian-Presario-C700-Notebook-PC:~$ fastboot devices

Nothing works!
Do you build under linux? Do you use an emulator or the S7 itself?

Sent from my Ideos S7 using Android Tablet Forum App
Do you build under linux? Do you use an emulator or the S7 itself?

Sent from my Ideos S7 using Android Tablet Forum App

I am running Ubuntu 10.10 on my PC. I have been using the S7 for testing anything that I have been building.

I have tried and tried and just can't fastboot at all, maybe my bootloader is screwed up.

What device ID are you guys seeing when you do adb devices? I get a very generic 1234567890ABCDEF, which I have not seen before.
Last edited:
To put the device in fastboot mode you should do this:
with your device shuted down press down the "-" sound key and kep presed then push the power buton and still keep presed the "-" sound key until the screen will be compleatly black(you will notice a blink first) now your device it will be on fastboot mode.
Well I have had no real problem getting in to fastboot (although I wish there was a GUI to confirm that the device is in fact in fastboot). I have tried on both my Ubuntu and Windows xp machines and I get no recognition of device in fastboot at all. In Ubuntu if I "lsusb" while the device is on it is recognized appropriately but when the device is in fastboot I "lsusb" and there is a different device ID and the description says "Google INC", it should say "Android Device Bootloader Fastboot" (or something similar). This sucks!! Well I can't really add much in the way of development if I have a locked or corrupted bootloader. I'm pretty much clueless, I have covered everything that I can think of. Thanks for all of your input guys.
no no if you get google inc then your in fastboot, I used to get the same thing man :)
(it puzzled me that they kept it as google inc but at least fastboot worked)