[ROM] Custom ROM for Coby Kyros 9742 - rooted, deodexed, Google Play

Not open for further replies.
Can someone help...

I rooted my 9742 with the files on the original post. It seems everything is now inverted, so I decided to unroot it with other files that people have posted on here, but the screen is still inverted. I found the post on another thread but is very difficult to fix with everything inverted, so I was hoping that someone could post a link to a new fixed version of the ROM file so I can fix this plz, or another solution to fixing the tablet.
OMG!!! Trying to locate stuff by inverted typing is NULL +1.5!!!!! I finally got it, it just took forever.
Really trying to get LiveSuite v1.07 to download so I can get out 9742 to connect with Google Play. V1.07 seem available only as a .RAR file. Never heard of one of those - I spent 36 years in the semiconductor end of things. Any body have a good reliable source of something that will read/unzip a .RAR file??
WinRAR archiver, a powerful tool to process RAR and ZIP files.

You'd do far better however installing Clockworkmod and flashing a ROM through Clockworkmod than using Livesuite. Your 9742 likely is newer than Steev's ROM, and between his ROM and mine the touchscreen drivers changed twice. The change has caused no end of grief since the touchscreen is rendered virtually useless until it's fixed.
I have a question about charging via the power cord. My 9742 is flashed with the rom from the other thread "9742 stock and custom rom" 9741 g333.zip and it initially (I think) charged on the cord but now it does not seem to recognize it. It only charges via USB on my comp (SLOW!!!). I have not tried usb via wall outlet using one of my android phone attachments.

Is this normal?
No it's not normal sounds like you have a bad charger, charging via USB is slow, that part is normal.
This isn't much, just a slight modification of the stock firmware with root, Google Play, and a few other changes.

This firmware was tested on a Novo 7 Elf and it worked fine, but you are solely responsible for its use.
If it bricks your tablet you've been warned.

- Gapps + Google Play fix
- Rooted
- NetworkLocation service fixed (to pinpoint your location in apps like Google Maps)
- Deodexed for easier modding/theming
- Samsung Galaxy tab fingerprint for better app compatibility

Version 0.1:

Flashing instructions:
- Download LiveSuite, this is the flashing software for A10 devices
- Run LiveSuitePack.exe (a bunch of files will be extracted to the current folder, so best to create a new one)
- Now run livesuite.exe
- Choose "SelectImage"
- Choose the coby_kyros_4.0.3.img
- Now you need to put your device in upgrade mode, to do so:
1. power off the device
2. Press and hold any physical key except the power key on the device(ie, press and hold Vol+ key, still holding in 3 and 4)
3. Connect the tablet to your PC via USB cable
4. Repeatedly press the power button until a popup dialog shows on your computer screen
- Now follow the on-screen instructions

Windows 7 64-Bit users, it has been reported that you need to use LiveSuite 1.0.7: LiveSuitPack_v1.07.rar

Thanks to all who posted firmware dumps and tested in this thread

Discussion is also taking place in this thread:
[ROM] Custom ROM for Coby Kyros MID9742 - Rooted, deodexed, Google Play

Hello and Thankyou for your time,

I just installed cfw_coby_9742_4.0.3_0.1 onto my COBY KYROS 9742 8GB, every thing went as expected during the upgrade process, the tablet rebooted into the new ROM but now my touch screen is all messed up. :confused:

At first I thought the touch screen was completely dead, so I plugged in a mouse.
I went into settings > Developer Options and enabled pointer location and show touch

I now can see that the touch screen is working, but XY axis seems to have flipped, when I touch bottom left corner, tablet shows pointer in top right

Anybody ever seen this? Every thing else seems to be working great.

Your input and ideas are greatly appreciated.

Thanks in advance!
Last edited by a moderator:
Please tell me that you made a dump of the stock ROM before you put Steev's ROM on your 9742?

In any case, the problem you're having was discussed and solved for some users here. I say some users because there are at least three different internal configurations of the 9742 and it's possible that the solution presented may not work for you. I hope you made that dump.
i tried to do it but i'm not sure if i succeeded. When livesuite finished there was a pop up but no words and just an exclamation point. Now the screen doesn't work. I can't press anything on the touch screen. What do i do? I just bought this earlier. What is going on? PLEASE HELP.
deocadez said:
i tried to do it but i'm not sure if i succeeded. When livesuite finished there was a pop up but no words and just an exclamation point. Now the screen doesn't work. I can't press anything on the touch screen. What do i do? I just bought this earlier. What is going on? PLEASE HELP.

That happened to me the first time I did it.... hold the power key till the tablet turns off and just try the process again I had to do it 3x before it flashed correctly and yea no words pop up just a blank pop up.
@RedDeer help! I'm not sure if I'm still on the right track. I followed your instructions and had successfully done upto the formatting the tablet. After it had format, I clicked the ok button. Then I saw my tablet to show the battery icon for a few moments and it turned black. It's been 10 minutes, and nothing has happened. The livesuit is still in 0%. I'm freaking out, I'm afraid it may void our warranty :(
Not open for further replies.